Commit 0c2861a5 authored by NanoDano's avatar NanoDano

Add version requirements to setup.py

- Added `python_requires` to specify less than 3.7,
- Updated `long_description` to be simpler reading from README
- Updated `install_requires` to pull from requirements.txt.
- Specified discord.py==0.16.12 since it is defaulting to new rewrite
parent ad57e22b
......@@ -2,7 +2,6 @@
Chat with existing bot
======================
You can join the DevDungeon.com Discord server and chat with the bot
in the ``#chat-with-cathy`` channel.
You can join the DevDungeon.com Discord server and chat with the bot in the ``#chat-with-cathy`` channel.
Use this link to join the Discord server: https://discord.gg/unSddKm
from setuptools import setup
def readme_file_contents():
with open('README.rst') as f:
data = f.read()
return data
setup(
name='cathy',
version='1.1.2',
version='1.1.3',
description='Discord chat bot using AIML artificial intelligence.',
long_description=readme_file_contents(),
long_description=open('README.rst').read(),
url='https://github.com/DevDungeon/ChattyCathy',
author='DevDungeon',
author_email='nanodano@devdungeon.com',
......@@ -29,10 +23,6 @@ setup(
],
},
zip_safe=False,
install_requires=[
'docopt',
'python-aiml',
'discord.py',
'requests'
]
install_requires=open('requirements.txt').read().splitlines(),
python_requires='<3.7',
)
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment